Skip to content

Commit b95a14c

Browse files
bryteiseclrpackages
authored andcommitted
Add distutils workaround
Work around pypa/setuptools#3007 Signed-off-by: William Douglas <william.douglas@intel.com>
1 parent 9c988d6 commit b95a14c

File tree

2 files changed

+6
-6
lines changed

2 files changed

+6
-6
lines changed

python3.spec

Lines changed: 5 additions & 5 deletions
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
Name: python3
22
Version: 3.10.1
3-
Release: 243
3+
Release: 244
44
License: Python-2.0
55
Summary: The Python Programming Language
66
Url: http://www.python.org
@@ -128,13 +128,13 @@ export NM=gcc-nm
128128
export LANG=C
129129
export CFLAGS="$CFLAGS -O3 -fno-semantic-interposition"
130130
%configure %python_configure_flags --enable-shared
131-
make %{?_smp_mflags}
131+
SETUPTOOLS_USE_DISTUTILS=stdlib make %{?_smp_mflags}
132132

133133
pushd ../Python-avx2
134134
export CFLAGS="$CFLAGS -march=x86-64-v3 -mno-vzeroupper "
135135
export CXXFLAGS="$CXXFLAGS -march=x86-64-v3 -mno-vzeroupper "
136136
%configure %python_configure_flags --enable-shared
137-
make %{?_smp_mflags}
137+
SETUPTOOLS_USE_DISTUTILS=stdlib make %{?_smp_mflags}
138138
popd
139139

140140
%install
@@ -158,15 +158,15 @@ mv %{buildroot}-v3/usr/lib/libpython*.so* %{buildroot}-v3/usr/lib64/
158158

159159
make clean
160160
%configure %python_configure_flags --enable-optimizations
161-
make profile-opt %{?_smp_mflags}
161+
SETUPTOOLS_USE_DISTUTILS=stdlib make profile-opt %{?_smp_mflags}
162162
%make_install
163163

164164
pushd ../Python-avx2
165165
make clean
166166
export CFLAGS="$CFLAGS -march=x86-64-v3 -mno-vzeroupper "
167167
export CXXFLAGS="$CXXFLAGS -march=x86-64-v3 -mno-vzeroupper "
168168
%configure %python_configure_flags --enable-optimizations
169-
make profile-opt %{?_smp_mflags}
169+
SETUPTOOLS_USE_DISTUTILS=stdlib make profile-opt %{?_smp_mflags}
170170
%make_install_v3
171171
popd
172172

release

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
243
1+
244

0 commit comments

Comments
 (0)